Database Maintenance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted 6 months ago. Dec 27, 2018 - 01:30 EST
Monitoring
We are performing database maintenance to mitigate a system performance issue. Users may experience degraded performance while maintenance is ongoing.
Posted 6 months ago. Dec 26, 2018 - 22:10 EST
This incident affected: api.stitchdata.com and app.stitchdata.com.