User Interface Outage
Incident Report for Stitch
Resolved
The user-interface has remained available and stable throughout our monitoring period.
Posted May 22, 2023 - 13:07 EDT
Monitoring
The user interface availability has been restored and we are continuing to monitor for stability.
Posted May 22, 2023 - 12:32 EDT
Identified
We've identified and are working to resolve a networking change that has affected the front-end availability.
Posted May 22, 2023 - 12:07 EDT
Investigating
Our team is currently investigating an issue that is preventing users from logging into and / or using the user-interface. We will provide updates as they become available.
Posted May 22, 2023 - 11:49 EDT
This incident affected: app.stitchdata.com.