Degraded Availability & Service
Incident Report for Stitch
Resolved
Functionality has remained consistent and without issue since our billing service's performance was restored.
Posted Aug 24, 2020 - 14:10 EDT
Monitoring
Our billing service has released a fix for this issue and we're continuing to monitor availability to take mitigating steps as necessary.
Posted Aug 24, 2020 - 11:36 EDT
Identified
Our billing service is encountering a partial outage, affecting Stitch account access and functionality. We're monitoring the situation closely to evaluate any necessary action to expedite availability.
Posted Aug 24, 2020 - 09:05 EDT
This incident affected: api.stitchdata.com and app.stitchdata.com.