Maintenance at 6:30PM EST
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Dec 01, 2016 - 18:18 EST
Investigating
Our engineering team will be performing routine maintenance tonight at 6:30PM EST. Customers may temporarily experience errors loading notifications in the Stitch UI.
Posted Dec 01, 2016 - 18:16 EST