Web App Outage
Incident Report for Stitch
Resolved
The issue has been resolved and the Web App should now be responsive again. Data pipelines have not been impacted.
Posted Jan 24, 2024 - 12:40 EST
Identified
We have identified the issue and are actively working on deploying the solution
Posted Jan 24, 2024 - 11:34 EST
This incident affected: app.stitchdata.com.