Degraded Performance In App

Incident Report for Stitch

Resolved

This incident has been resolved. App loading times are back to normal and our third-party service provider has resolved the issue.
Posted Dec 15, 2021 - 11:41 EST

Monitoring

App loading times have returned to normal and we are monitoring requests sent to our third-party service provider.
Posted Dec 15, 2021 - 11:10 EST

Identified

App loading times are currently being affected by an issue impacting a third-party service provider.
Posted Dec 15, 2021 - 10:58 EST

Investigating

We are currently investigating increased latency in app loads. Extractions and load jobs are running as expected.
Posted Dec 15, 2021 - 10:43 EST
This incident affected: app.stitchdata.com.