Extraction issues

Incident Report for Stitch

Resolved

This issue has been resolved. We apologize for the inconvenience and appreciate your patience.
Posted May 30, 2025 - 06:10 EDT

Monitoring

The issue has been fixed and the team is monitoring the results.
Posted May 30, 2025 - 05:34 EDT

Identified

The issue has been identified, and our team is actively working on mitigation and implementing a fix.
Posted May 30, 2025 - 05:30 EDT

Update

Our team is continuing to diligently work on resolving the issue. We will keep you posted on any further updates.
Posted May 30, 2025 - 04:18 EDT

Investigating

We're investigating an issue affecting Extractions in Stitch Cloud and are diligently working to resolve the issue as soon as possible.
We'll provide new information as it becomes available while the issue is being addressed. We apologize for any inconvenience and appreciate your patience.
Posted May 30, 2025 - 03:25 EDT
This incident affected: api.stitchdata.com and app.stitchdata.com.