Stitch API calls to Meta for data are interrupted

Incident Report for Stitch

Resolved

This issue has been resolved. We apologize for the inconvenience and appreciate your patience.
Posted Mar 23, 2026 - 08:16 EDT

Monitoring

The issue has been fixed and the team is monitoring the results.
Posted Mar 23, 2026 - 04:56 EDT

Investigating

Our team has identified an issue where Stitch API calls to Meta for data are interrupted. Our team is investigating the issue and will keep you posted at the earliest
Posted Mar 23, 2026 - 04:30 EDT
This incident affected: api.stitchdata.com and app.stitchdata.com.