Increased latency loading the app
Incident Report for Stitch
Resolved
Latency has returned to normal.
Posted Jan 31, 2017 - 16:43 EST
Investigating
We are experiencing increased latency loading the UI. We are investigating.
Posted Jan 31, 2017 - 16:06 EST