Stitch - UI issues

Incident Report for Stitch

Resolved

This issue has been resolved. We apologize for the inconvenience and appreciate your patience.
Posted Mar 12, 2026 - 09:45 EDT

Monitoring

The issue has been fixed and the team is monitoring the results.
Posted Mar 12, 2026 - 09:15 EDT

Investigating

We’re investigating an issue impacting the ability to open Stitch UI and are diligently working to resolve the issue as soon as possible. Updates will be provided as new information becomes available during the resolution process. We apologize for any inconvenience and appreciate your patience.
Posted Mar 12, 2026 - 09:12 EDT
This incident affected: app.stitchdata.com.