Issue Navigating to Add Integration and Add Destination Pages
Incident Report for Stitch
Resolved
The Add Integration page and Add Destination page were affected by an issue impacting a third-party service provider that resulted in an error indicating, "Something Went Wrong" and prevented the creation of new integrations or an account's destination. This issue has been resolved by the service provider and ability to access these pages has been restored.
Posted Jun 09, 2021 - 09:00 EDT