User login issues
Incident Report for Stitch
Resolved
There should no longer be issues with logging into the app.
Posted Dec 01, 2022 - 10:54 EST
Monitoring
The issue has been identified and fixes have been implemented. There may still be lingering issues but we are actively monitoring.
Posted Dec 01, 2022 - 09:30 EST
Investigating
We have identified an issue where users are unable to log into their accounts. We are currently investigating.
Posted Dec 01, 2022 - 04:34 EST
This incident affected: app.stitchdata.com.