Latency issue with Stitch App

Incident Report for Stitch

Resolved

The issue seems to have resolved
Posted Dec 05, 2023 - 05:39 EST

Investigating

We are currently facing latency issue with our app. In the process of investigating the issue
Posted Dec 05, 2023 - 05:15 EST
This incident affected: app.stitchdata.com.