Degraded Performance: app.stitchdata.com
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Nov 09, 2016 - 13:56 EST
Identified
We are experiencing degraded performance on app.stitchdata.com due to unplanned database maintenance. Our team is aware of the issue and working to resolve it.
Posted Nov 09, 2016 - 13:38 EST