Snowflake Loading Issues
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Mar 04, 2024 - 16:08 EST
Monitoring
A fix has been implemented to resolve the data duplication issue on some Snowflake customer environments. Impacted customers may experience load performance lag temporarily during this time.

We are continuing to monitor the situation closely.
Posted Mar 01, 2024 - 17:11 EST
Identified
We have identified an issue where some Stitch Snowflake loading processors are working on the same sets of data at the same time, which is causing duplicate data to be loaded on some customer Snowflake environments.

We are working to address the issue to stop the data duplication as soon possible.
Posted Mar 01, 2024 - 15:43 EST
Investigating
We are currently investigating an issue causing duplicate records on some Snowflake destinations.
Posted Feb 29, 2024 - 09:54 EST