Stitch Support Availability
Incident Report for Stitch
Resolved
Our chat service has marked the issue as resolved. We are available via the chat bubble.
Posted 11 months ago. Jun 12, 2018 - 11:47 EDT
Identified
Stitch Support is temporarily unavailable while an issue impacting our chat provider is addressed. Thank you for your patience.
Posted 11 months ago. Jun 12, 2018 - 10:44 EDT