Issues creating new JIRA integrations
Incident Report for Stitch
Resolved
This issue has been resolved.
Posted Apr 18, 2017 - 12:15 EDT
Investigating
We're seeing reports of issues creating new JIRA integrations. We are investigating.
Posted Apr 14, 2017 - 17:01 EDT