Freshdesk Inaccessible
Incident Report for Stitch
Resolved
The issues connecting to the Freshdesk API have been resolved.
Posted Apr 21, 2017 - 13:05 EDT
Identified
We have identified the issue and are working with Freshdesk to resolve it.
Posted Mar 10, 2017 - 15:58 EST
Investigating
We are currently experiencing issues connecting to the Freshdesk API. Our team is working on a resolution and will provide updates as we have more information.
Posted Mar 09, 2017 - 15:51 EST